Virtualization Station "failed to synchronize time in virtual machine".

Hi Everyone,

When I suspend and then resume my Ubuntu Server 24.04 virtual machine, I get the error “failed to synchronize time in virtual machine”. QNAP’s support documents suggest installing “Guest Tools CD” and having “Virtio-serial” enabled. I have “Virtio-serial” enabled but there don’t seem to be any guest tools for Linux on the “Guest Tools CD” image. I have found forum posts on the Internet that suggest installing “qemu-guest-agent” but that doesn’t make any difference.

Anyone have suggestions on how to cure this issue?

Another acceptable workaround would be that the virtual machine shuts down on power loss rather than suspend.

Thanks.

QNAP TVS-h1288X
QuTS Hero v6.0.2.3591
Virtualization Station v4.2.1.66

When the VM time sync fails, roughly how large is the time difference between the two devices usually? Thanks!

There is no Guest Tools CD image for Linux installs. That’s for Windows only.

I have seen this before and I think it’s just the fact that when the VM first wakes up, all the network connections aren’t active and it attempts to sync the time and fails. After a few minutes, it tries again and all should be fine.